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13.1. Introduction

13.1.1. Program’s function

NextGIS Formbuilder program is aimed to create, edit and configure forms, which are used in

NextGIS Mobile/Collector for field data collection.

This documentation describes NextGIS Formbuilder version 3.0.

13.1.2. Licence

Formbuilder is licensed under GPL v.2.

13.1.3. System requirements

Operating System: Microsoft Windows 10 64bit and above.

13.1.4. Installation and launch

Download NextGIS unified installer from https://nextgis.com/nextgis-formbuilder/ and launch.

Follow the installer steps. After downloading, use the shortcut, which appears on the desktop or

in the Start menu.
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13.2. User interface description

The program looks like this by default: (Pic. 13.1.).

Pic. 13.1. Formbuilder’s GUI

Numbers show: 1 - main menu; 2 - main toolbar; 3 - “Updates available” icon; 4 - authorization

button; 5 - “device” screen; 6 - “elements” menu; 7 - “Data” menu; 8 - “Properties” menu.

You can change the position, size and visibility of the side menus:

Hover your mouse cursor over the menu and press the left button to transfer it to a

different place;

Pull the menu’s edges to change its width and height;

Press the close button to hide menu. You can make it visible again in the main menu
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section “view”.

13.2.1. Main menu

The main menu consists of the following submenus:

File

New. Create a new blank project.

Open. Open project from .ngfp file.

Save. Save project to .ngfp file.

Save as…. Save project to another .ngfp file.

Exit. Exit application.

Edit

Download from NextGIS. Download form (and data) from your web GIS by selecting an

existing layer.

Upload to NextGIS. Send a form to your web GIS with creating a new layer.

Form properties. Edit the main properties of the form: form’s name and geometry type of

the layer.

Clear form. Delete all elements from the form.

Bind elements to fields. Turn on/off the automatic field creation mode. While the mode is

ON when new elements are placed on the form, fields of a layer are automatically created

and attached to the elements.

View

Toolbars. Hide/show different menus and interface panels.

Settings

Language. Choose interface language. Reload Formbuilder for changes to start working.

Help

View help. Open the help page in browser.

Need commercial support?. Open commercial support page in browser.

About. Show About dialog. Also contains information about your account.

13.2.2. Main toolbar

Contains fast-access buttons to subsections of the main menu. Move the mouse over the button



to see its name (in a popup message) and description (in the program’s status bar below).

 Note

Some toolbar buttons may be inaccessible, which is shown by a “lock” icon on the button. To

get full access to all functions in the program: complete authorization, if subscribed you will

gain access to a complete functionality.

13.2.3. “Updates available” icon

A green square icon with an arrow (the top right corner by default) will be shown only if updates

are available (Windows and Mac OS only). If icon is not shown, then there are no updates, or the

program failed to connect to the update server. Click on icon to update the program: Formbuidler

will close (with a suggestion to save the project if there are changes) and update dialog will open.

Follow the steps of the installation wizard. After the dialog finishes working, the program will

restart automatically.

Alternatively, you can run the NextGIS update wizard as a separate program from the NextGIS

installation directory.

13.2.4. Authorization

The button with the avatar image (the top right corner by default) allows you to sign in with

NextGIS services and get the extended functionality of the program if you have a subscription.

Press the button, then in the pop-up window press “Sign in”. In the opened browser page enter

your email and password of your NextGIS ID, after that return to the program. Check that you

have a “supported” account by clicking on the authorization button again. (How to create

NextGIS ID account)

To log off press the authorization button once again and press “Sign out” in the pop-up window.

 Note

Authorization needs to be completed only once. The next time you start the program, you will

sign in automatically. Please note that after launching the program it may take several seconds

before the blocked functionality becomes available.

If you want to log into another account, sign out both in the program and in the browser.

13.2.5. On-premise Authorization

If you want to login via the on-premise, you must specify the appropriate Endpoint in the

authorization settings (Main menu -> Settings -> Authorization) (Pic. 13.2.).

https://docs.nextgis.com/docs_ngcom/source/create.html


Pic. 13.2. Adding your own authorization server

13.2.6. Device screen

This is a screen layout of the real device on which data will be collected in NextGIS

Mobile/Collector. It is designed to create a form: i.e. for placing, moving and grouping the

elements of which the form consists and with the help of which the data about one object of the

layer will be entered at the moment of data collection. elements in the form are arranged

vertically, one after another. It is possible to group items by named tabs.

To add an element to the form - start dragging it with the cursor, while holding the left mouse

button, from the “elements” menu (left by default) - the cursor will take the form of a squeezed

hand. Alternatively, you can quickly add an element to the end of the form by clicking on it one

time with the left mouse button, pressing the Ctrl key in the elements panel.

To select an element - click the left button on it once in the form. A red dotted frame will appear

around the element.

To move an element - drag it by pressing the left button to any place on the form.

To delete an item, select it and press the Delete key on the keyboard. Deleting an item cannot be

undone. Be aware of the fact that when you delete an element, the associated field(s) of the layer

will also be deleted.

13.2.7. Form elements

This menu contains a list of all available elements that can be created on the form. Hover over an

element to see tooltip with its description.

https://docs.nextgis.com/_images/Endpoint_Formbuilder_en.png
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To add an element to a form drag it holding left mouse button onto the device screen in the

middle (the pointer will look like a squeezed hand). Alternatively you can quickly add an element

to the end of the form by left-click + Ctrl.

 Note

Some elements may be inaccessible, which is shown by a “lock” icon on the button. To get

access to the full functionality, log in and make sure you have a corresponding subscription

plan.

13.2.8. “Data” menu

This menu contains a table of layer fields. In the Formbuilder program, only one form is edited in

one project, tied to only one layer. Layer’s field(s) are created automatically when elements are

added to a form. an element may have from 0 to 2 related fields. To see what elements are

attached to what fields - select the element: if any fields are attached to the element, they will be

highlighted in bold in the table.

When creating elements for fields, their name, alias and type are automatically generated:

Name cannot be changed;

Alias can be changed in the corresponding text string in the table. Type a new name in this

line, the changes will be saved automatically;

Type can be changed in the corresponding drop-down list in the table. Select the required

data type from the drop-down list - the changes will be saved automatically. Please note

that the field type depends on the element itself and its properties (for example, the Date

and Time element can save only “Date / Time” and “String” values ​​at the time of data

collection, but cannot store an “Integer” value). For some elements, you can change their

properties so that the corresponding data types become available (for example to allow a

text field to inout only numeric values ​​— set the “Only numbers” property in the

“Properties” menu table and change the data type of the field to “Integer” in the menu

table “Data”).

13.2.9. “Properties” menu

This menu contains the table of properties of the selected element. Select an element by clicking

on it with the left mouse button. Change the properties in the table that appears - changes to the

element will be saved automatically. Please note: a change in one property may entail a change in

another property of this element due to their incompatibility or mutual influence on each other.

Changing the properties of an element also leads to an increase or decrease in the number of

available types for fields, associated with the element: you can track this in the “Data” menu table.
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13.3. Working with the program

13.3.1. Create a new local form

1. Run the program. Select File -> New;

2. Specify the type of geometry for the data to be collected. Select: Edit -> Form Properties and in

the opened dialog select the type of geometry needed, then click OK;

3. Add the necessary elements to the form, arranging them in the desired order. If necessary,

follow the additional steps (can be skipped):

choose different aliases for the fields and rename them, pick the necessary types in the

“Data” menu.

set the element’s properties in the “Properties” menu;

4. Save project to file. Select File -> Save and specify the path to the file. In result the file with the

.ngfp extension is ready for uploading to NextGIS Mobile and for using it to collect data.

 Note

To collect data on your mobile device follow the NextGIS Mobile instructions. After the

collection is complete, you can receive the collected data as a separate file. In NextGIS Mobile,

select: Main menu -> find the layer in which the data was collected -> action button with a

layer (three dots) -> Share -> in the pop-up dialog select the method for obtaining the final file

(ZIP archive with GeoJSON data).

13.3.2. Edit local form

1. Run the program. Select: File -> Open. Specify the path to the file with the .ngfp extension;

2. Make the necessary changes to the form;

3. Save project to file. Select: File -> Save. The resulting file with the .ngfp extension can be

uploaded to a mobile device as a new layer.

13.3.3. Create a new form in NextGIS Web

1. Run the program. Create a new project or open an existing one from an .ngfp file;

2. Set the mode, which automatically creates fields, when elements are created. The button “Bind
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elements to fields” should be in pressed state;

3. Add the necessary elements to the form, arranging them in the desired order. If necessary,

follow the additional steps (can be skipped):

choose different aliases for the fields and rename them, pick the necessary types in the

“Data” menu.

set the element’s properties in the “Properties” menu;

4. To send ready form to your web GIS, select: Edit -> Upload to NextGIS;

5. In the dialog that opens, specify the connection parameters and click the “Connect” button:

URL (name) of your web GIS, for example demo.nextgis.com;

select the “guest” checkbox if you want to connect to Web GIS without a login and

password. Note: in this case, data collection by using the form may become unavailable

- it all depends on the settings of NextGIS Web rights for the guest account;

login;

password.

6. In the list of resource groups that appear, select a resource group and click the “Select”

button. In the dialog that opens after this (see Pic. 13.3.) , check the name of the new layer and

the type of the geometry and change them if necessary.



Pic. 13.3. Form properties dialog

In this dialog you can chose what resources to create in the WebGIS. By default, a new vector

layer with the field structure, defined in the project, will be created in Web GIS, and the created

form will be uploaded to it. You can add this layer as an item to an existing Collector project. In

addition to that, you can also create:

a new Collector project (a data collection project and a basemap will be created)

a new Web Map

To do so, tick the corresponding settings in the dialog.

Click the “Send” button.

https://docs.nextgis.com/_images/ngfb_webgis_prop_en.png


If it wasn’t possible to create a layer (there is no connection to the Internet, the name of the layer

is not unique, etc.), a corresponding message will appear.

If the name of the layer is not unique, you can change it either by selecting Edit -> Form Properties

-> Name (by default the name is “Layer”), or when uploading the form to WebGIS.

 Note

To collect data on your mobile device follow the instructions of NextGIS Mobile/Collector.

The data collected by using the form will be synchronized with the layer automatically.

13.3.4. Create a new form in NextGIS Web for an existing
layer

1. Run the program. Select: Edit -> Download from NextGIS;

2. In the dialog that opens, specify the connection parameters and click the “Connect” button:

URL (name) of your web GIS, for example demo.nextgis.com;

select the “guest” checkbox if you want to connect to Web GIS without a login and

password. Note: in this case, not all layers or resource groups may be visible - it all

depends on the settings of NextGIS Web rights for the guest account;

login;

password.

3. In the resource list that appears, select a resource with the “Vector layer” type and click the

“Select” button. If the connection is successful, the data structure of the layer will be

uploaded, as well as the existing form (if it already exists for the selected layer);

4. Make changes to the form. If there is no form initially, but you need to create it for an existing

field structure - turn off the automatic field creation mode: the button “Bind elements to

fields” should be in unpressed state. Place elements on the form. After that, connect the the

fields with these elements through the “Field Layer” property in the “Properties” menu of the

element. As a result, in the “Data” menu all fields should have green “ok” markers, indicating

that the fields are successfully connected with the elements, and the elements themselves

should not have red markers with an exclamation mark.

5. Upload the modified form to NextGIS Web (see the section “Creating a New Form in NextGIS

Web”). Please note that you cannot change existing resources this way; in any case, a new

layer will be created and a form will be uploaded to it. If the layer you selected at the beginning

had data, then this data will be copied to the new layer if fields match.

See how it works in our video:
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13.4. Form elements

This toolbar contains elements that can be added to a form. Hover over an element to see tooltip

with its description.

Pic. 13.4. Elements panel

To add an element to a form drag it holding left mouse button onto the device screen in the

middle (the pointer will look like a squeezed hand). Alternatively you can quickly add an element

to the end of the form by left-click + Ctrl.

 Note

Some elements may be inaccessible, they are marked by a lock sign. To get access to the full
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functionality, log in and make sure you have a corresponding subscription plan.

Elements available without logging in: date & time, combobox, checkbox, label, radiogroup, text

edit, void space.

Elements only available in Pro version: average counter, coordinates, counter, dependent

comboboxes, distance meter, photo, signature field, split combobox, tabs.

Quick overview of the form elements on youtube:

Date&Time, Photo and Text field.

Radiogroup and Checkbox.

Long text field and collector’s login.

13.4.1. Tabs

Tabs are used to group other elements. You can add multiple tab sets to a form and manage the

number of tabs in each of them.

In a form, some elements can be in tabs while others are outside tab sets.

To add a tab set, drag “Tabs” element to the form. On the right is the Properties panel of the tab

set.

In this panel you can switch between tabs of the set and open the tab modifying dialog.

https://docs.nextgis.com/docs_collector/source/index.html
https://docs.nextgis.com/docs_ngtracker/source/index.html
https://docs.nextgis.com/docs_ngid/source/index.html
https://docs.nextgis.com/docs_ngweb_dev/doc/toc.html
https://docs.nextgis.com/ngmobile_dev/source/toc.html
https://docs.nextgis.com/qms_srv_dev/doc/api.html
https://youtu.be/zWrKaT-SZZo?si=_kJd62vNdVdgg4RL
https://youtu.be/cwNwe5p_dbw?si=OigWL54fPNPrtmFW
https://youtu.be/3SVWfRty700?si=rZVQcOj2sX33gFE4


Pic. 13.5. Switching between tabs. Current tab 1 is marked in blue in the form
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Pic. 13.6. Editing tab set

In the Modify dialog you can:

Change tab headers (default names are “Tab”+№)

Add new tabs to the set (enter a name for the new tab to the yellow field at the bottom)

Delete tabs

13.4.1.1. Adding elements to tabs

To add an element to a tab, drag it to it. The element will be added to the active tab marked in blue.

Make sure that the element is within the tab set. To see the tab set edges (red dashed line) click on

the set.

https://docs.nextgis.com/_images/fb_tabs_properties_en.png


Pic. 13.7. Adding elements to a tab and outside the tab set

A form can have multiple tab sets as well as elements outside sets.

https://docs.nextgis.com/_images/fb_folders_insideout_en.png


Pic. 13.8. Possible placement of elements and tabs.

Elements placed in the tab that is not currently active are hidden. To edit them, switch to that tab

using Properties panel.

If a tab set is deleted, all elements of each tab will also be deleted. To avoid accidental deleting, a

confirmation dialog will appear.

https://docs.nextgis.com/_images/fb_folders_example_en.png


Pic. 13.9. Confirmation dialog for deleting a tab set

13.4.2. Date and time

This elements allows to enter date, time or date+time.

Properties:

Keep last value. The default value will be the last entered.

Initial value. You can set a default value so that collector changes it only if necessary.

Current. If checked, the element will automatically save the date and time of data collection. If

unchecked, collector enters date and time manually.

Type. Date; time; or date + time.

https://docs.nextgis.com/_images/fb_folders_del_confirm_en.png


Pic. 13.10. Date & time element and its properties

13.4.3. Distance meter

This element automatically measures distance between data collector and the entered point.

13.4.4. Coordinates

This element automatically saves current position of the data collector in string format.

Contains two fields: latitude and longitude.

Properties:

Fields can be interchanged. Choose the field number from the dropdown menu.

Hide. The element will not be visible in the form, but the coordinates will be saved anyway.

CRS. Displays Coordinate reference system used for data collection (ESPG:4326).

Format. Displays coordinate format (decimal degrees).

13.4.5. Label
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This element allows adding text labels to the form.

Properties:

Text. Edit the text visible in the form.

13.4.6. Signature field

Field for a signature

13.4.7. Void space

An empty field to create spaces between elements.

Pic. 13.11. Form with void spaces

13.4.8. Radiogroup

A list of predetermined values (data collector chooses only one item from the list).

Properties:
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Keep last value. The default value will be the last entered.

Items. Press Modify to edit the list (it must contain at least two items).

Field. Select the layer field to store the data from this element.

Pic. 13.12. Editing radiogroup

Modifying radiogroup allows to make following changes:

Add new item (enter it into the yellow row with “*” for number and press Enter or “+” button

on the right)

Clear list of items

Load items from .csv file

Add items from the last row - saves value entered in the yellow field and creates a new empty

row for value entering

Remove selected row

Set as default value

To load a list from a file, press  button with green mark above the table. Keep in mind that the

current items will be cleared and replaced with items from the CSV file, a warning will appear

before loading.
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Select CSV file with the list on your device. The list must contain 2 to 16 rows.

In the next dialog select the columns for the value and the corresponding display text. A list form

from these two columns will appear in the table. Save the list by pressing Ok. It will appear in the

form.

Pic. 13.13. Loading list from CSV file

To clear the list and enter new items manually, press  button with red broom on it above the

table.

13.4.9. Combobox

A dropdown menu to select one value from a predetermined list.

Properties:

Input with search. User can start typing to find available items.

Keep last value. The default value will be the last entered.

Items. Here you can edit the list of possible values.

Field. Select the layer field to store the data from this element.
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Custom items. Data collector can enter new items to the list.

Pic. 13.14. Edit list

Modifying combobox allows to make following changes:

Add new item (enter it into the yellow row with “*” for number and press Enter or “+” button

on the right)

Clear list of items

Load items from .csv file

Add items from the last row - saves value entered in the yellow field and creates a new empty

row for value entering

Remove selected row

Set as default value

To load a list from a file, press  button with green mark above the table. Keep in mind that the

current items will be cleared and replaced with items from the CSV file, a warning will appear

before loading.

Select CSV file with the list on your device. The list must contain 2 to 65536 rows.
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In the next dialog select the columns for the value and the corresponding display text. A list form

from these two columns will appear in the table. Save the list by pressing Ok. It will appear in the

form.

To clear the list and enter new items manually, press  button with red broom on it above the

table.

13.4.10. Split combobox

Dropdown list with predetermined items split into two parts. For instance, showing a place name

in two different languages.

Properties:

Caption (left). Text displayed above the left list.

Caption (right). Text displayed above the right list.

Keep last value. The default value will be the last entered.

Items. Press Modify to edit the list.

Pic. 13.15. Modifying items in a split combobox
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13.4.11. Dependent comboboxes

A pair of drop-down lists with predefined items. The item list of the dependent combobox

(bottom) depends on the items of the main combobox (top).

Example:

Main list - a list of regions (1. Auvergne-Rhône-Alpes; 2. Bourgogne-Franche-Comté)

Dependent list - departments of the regions (1.1. Ain, 1.2. Allier etc; 2.1. Côte-d’Or, 2.2. Doubs

etc)

Properties:

Items. Here you can edit the list of possible values.

Keep last value. The default value will be the last entered.

Pic. 13.16. Editing dependent list of the comboboxes

13.4.12. Counter

An element which automatically adds values based on some predefined format.
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Properties:

Increment. The value which is added to the current counter’s value each time user collects

data about an object. Integer, 1 to 999999999.

Initial value. Initial value from which the counter starts. Integer, 0 to 999999999.

Field. Select the layer field to store the data from this element.

Prefix. Text added before the counter’s value. If this text is not void the counter writes its

value as a string. If it is void, the field type can be modified. You can enter the value manually or

use Prefix from list and add a predetermined list to select a prefixe from.

Suffix. A text which is added after the counter’s value. If this text is not void the counter writes

its value as a string. If it is void, the field type can be modified. You can also use Suffix from list.

To create a list of prefixes or suffixes, in the top panel open the Edit menu and select “Edit

prefixes”. Each column is a separate list.

Pic. 13.17. Lists of prefixes and suffixes
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Watch on youtube.

13.4.13. Average counter

An element which calculates the average value from some amount of entered values. Includes an

interactive Count button.

Properties:

Number of values. How many values data collector should enter to calculate an average value.

Field. Select the layer field to store the data from this element.

https://youtu.be/2G4p7_qO6GE?si=U9PnRJpEuquZSQW2


Pic. 13.18. Average counter

13.4.14. Text edit

An element for editing simple text or numbers.

Properties:

Initial text. The text displayed in the field by default.

Keep last value. The default value will be the last entered.

Max. lines count. Maximum number of lines for this text edit field. Integer, 1 to 256.

NextGIS ID login. This field will automatically store NextGIS ID used by the data collector to

log in. If you select this option, other properties except field selection are unavailable.

NextGIS Web login. This field will automatically store NextGIS Web login used by the data

collector to log in. If you select this option, other properties except field selection are

unavailable.

Field. Select the layer field to store the data from this element.

Only numbers. If checked, this element can only accept numbers.
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Pic. 13.19. Three text fields in the form: plain text, NextGIS ID and NextGIS Web login

13.4.15. Checkbox

An element which allows user to pick from two values: true or false.

Properties:

Keep last value. The default value will be the last entered.

Initial value. If this property is checked, the default value of the checkbox is “true”.

Text. Display text.
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Next 

Pic. 13.20. Checkbox set to default value “true”

13.4.16. Photo

An element which allows to take photos with the camera of the device or to add them from the

gallery.

Properties:

Max. photo count. Maximum number of photos. Integer, 1 to 20.

Comment. Comment under photo(s).
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