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Глава

ONE

INTRODUCTION

1.1 Program’s function

NextGIS Formbuilder program is aimed to create, edit and configure forms, which
are used in NextGIS Mobile/Collector for field data collection.

This documentation describes NextGIS Formbuilder version 3.0.

1.2 Licence

Formbuilder is licensed under GPL v.21.

1.3 System requirements

OS: Microsoft Windows XP/7/10, MacOS.

1.4 Installation and launch

Download NextGIS unified installer from http://nextgis.com/nextgis-formbuilder/
and launch. Follow the installer steps. After downloading, use the shortcut, which
appears on the desktop or in the Start menu.

1 https://docs.nextgis.com/docs_ngweb/source/appendix.html#ngw-gplv2
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USER INTERFACE DESCRIPTION

The program looks like this by default: (Fig. ??).

Рис.2.1: Formbuilder’s GUI
Numbers show: 1 - main menu; 2 - main toolbar; 3 - “Updates available” icon; 4 -
authorization button; 5 - “device” screen; 6 - “Controls” menu; 7 - “Data” menu; 8 -

“Properties” menu.

You can change the position, size and visibility of the side menus:

• Hover your mouse cursor over the menu and press the left button to transfer
it to a different place;
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• Pull the menu’s edges to change its width and height;

• Press the close button to hide menu. You can make it visible again in the main
menu section “view”.

2.1 Main menu

The main menu consists of the following submenus:

File

• New. Create a new blank project.

• Open. Open project from .ngfp file.

• Save. Save project to .ngfp file.

• Save as. . . . Save project to another .ngfp file.

• Exit. Exit application.

Edit

• Download from NextGIS. Download form (and data) from your web GIS by
selecting an existing layer.

• Upload to NextGIS. Send a form to your web GIS with creating a new layer.

• Form properties. Edit the main properties of the form: form’s name and
geometry type of the layer.

• Clear form. Delete all controls from the form.

• Bind elements to fields. Turn on/off the automatic field creation mode.
While the mode is ON when new controls are placed on the form, fields of
a layer are automatically created and attached to the controls.

View

• Toolbars. Hide/show different menus and interface panels.

Settings

• Language. Choose interface language. Reload Formbuilder for changes to
start working.

Help

• View help. Open the help page in browser.

• Need commercial support?. Open commercial support page in browser.

• About. Show About dialog. Also contains information about your account.

2.1. Main menu 3
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2.2 Main toolbar

Contains fast-access buttons to subsections of the main menu. Move the mouse
over the button to see its name (in a popup message) and description (in the
program’s status bar below).

Note: Some toolbar buttons may be inaccessible, which is shown by a “lock”
icon on the button. To get full access to all functions in the program: complete
authorization, if subscribed you will gain access to a complete functionality.

2.3 “Updates available” icon

A green square icon with an arrow (the top right corner by default) will be shown
only if updates are available (Windows andMac OS only). If icon is not shown, then
there are no updates, or the program failed to connect to the update server. Click
on icon to update the program: Formbuidler will close (with a suggestion to save
the project if there are changes) and update dialog will open. Follow the steps of
the installation wizard. After the dialog finishes working, the program will restart
automatically.

Alternatively, you can run the NextGIS update wizard as a separate program from
the NextGIS installation directory.

2.4 Authorization

The button with the avatar image (the top right corner by default) allows you to
sign in with NextGIS services and get the extended functionality of the program if
you have a subscription. Press the button, then in the pop-up window press “Sign
in”. In the opened browser page enter login and password of your NextGIS ID,
after that return to the program. Check that you have a “supported” account by
clicking on the authorization button again.

To log off press the authorization button once again and press “Sign out” in the
pop-up window.

Note: Authorization needs to be completed only once. The next time you start
the program, you will sign in automatically. Please note that after launching the
program it may take several seconds before the blocked functionality becomes
available.

If you want to log into another account, sign out both in the program and in the
browser.

2.2. Main toolbar 4



NextGIS Formbuilder documentation, Release 2.0

2.5 On-premise Authorization

If you want to login via the on-premise, you must specify the appropriate Endpoint
in the authorization settings (Main menu -> Settings -> Authorization) (Fig. ??).

Рис.2.2: Adding your own authorization server

2.6 Device screen

This is a screen layout of the real device on which data will be collected in NextGIS
Mobile/Collector. It is designed to create a form: i.e. for placing, moving and
grouping the controls of which the form consists and with the help of which the
data about one object of the layer will be entered at the moment of data collection.
Controls in the form are arranged vertically, one after another. It is possible to
group items by named tabs.

To add a control to the form - start dragging it with the cursor, while holding the
left mouse button, from the “Controls” menu (left by default) - the cursor will take
the form of a squeezed hand. Alternatively, you can quickly add a control to the
end of the form by clicking on it one time with the left mouse button, pressing the
Ctrl key in the Controls panel.

To select a control - click the left button on it once in the form. A red dotted frame
will appear around the control.

To move a control - drag it by pressing the left button to any place on the form.

To delete an item, select it and press the Delete key on the keyboard. Deleting an
item cannot be undone. Be aware of the fact that when you delete a control, the
associated field(s) of the layer will also be deleted.

2.5. On-premise Authorization 5
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2.7 “Controls” menu

This menu contains a list of all available controls that can be created on the form.
Hover the cursor over an item to see its description in a pop-up message.

To add a control to the form - start dragging it with the cursor, while holding the
left mouse button, from the “Controls” menu (left by default) - the cursor will take
the form of a squeezed hand. Alternatively, you can quickly add a control to the
end of the form by clicking on it one time with the left mouse button, pressing the
Ctrl key in the Controls panel.

Note: Some controls may be inaccessible, which is shown by a “lock” icon on the
button. To get full access to all functions in the program: complete authorization,
if subscribed you will gain access to a complete functionality.

2.8 “Data” menu

This menu contains a table of layer fields. In the Formbuilder program, only one
form is edited in one project, tied to only one layer. Layer’s field(s) are created
automatically when controls are added to a form. A control may have from 0 to 2
related fields. To see what controls are attached to what fields - select the control:
if any fields are attached to the control, they will be highlighted in bold in the table.

When creating controls for fields, their name, alias and type are automatically
generated:

• Name cannot be changed;

• Alias can be changed in the corresponding text string in the table. Type a
new name in this line, the changes will be saved automatically;

• Type can be changed in the corresponding drop-down list in the table. Select
the required data type from the drop-down list - the changes will be saved
automatically. Please note that the field type depends on the control itself and
its properties (for example, the Date and Time control can save only “Date /
Time” and “String” values at the time of data collection, but cannot store an
“Integer” value). For some controls, you can change their properties so that
the corresponding data types become available (for example to allow a text
field to inout only numeric values — set the “Only numbers” property in the
“Properties” menu table and change the data type of the field to “Integer” in
the menu table “Data”).

2.7. “Controls” menu 6
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2.9 “Properties” menu

This menu contains the table of properties of the selected control. Select a control
by clicking on it with the left mouse button. Change the properties in the table
that appears - changes to the control will be saved automatically. Please note: a
change in one property may entail a change in another property of this control due
to their incompatibility or mutual influence on each other. Changing the properties
of a control also leads to an increase or decrease in the number of available types
for fields, associated with the control: you can track this in the “Data” menu table.

2.9. “Properties” menu 7
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WORKING WITH THE PROGRAM

3.1 Creating a new local form

1. Run the program. Select File -> New;

2. Specify the type of geometry for the data to be collected. Select: Edit -> Form
Properties and in the opened dialog select the type of geometry needed, then
click OK;

3. Add the necessary controls to the form, arranging them in the desired order.
If necessary, follow the additional steps (can be skipped):

• choose different aliases for the fields and rename them, pick the
necessary types in the “Data” menu.

• set the control’s properties in the “Properties” menu;

4. Save project to file. Select File -> Save and specify the path to the file. In
result the file with the .ngfp extension is ready for uploading to NextGIS
Mobile and for using it to collect data.

Note: To collect data on your mobile device follow the NextGIS Mobile
instructions. After the collection is complete, you can receive the collected data as
a separate file. In NextGIS Mobile, select: Main menu -> find the layer in which
the data was collected -> action button with a layer (three dots) -> Share -> in
the pop-up dialog select the method for obtaining the final file (ZIP archive with
GeoJSON data).

3.2 Changing the local form

1. Run the program. Select: File -> Open. Specify the path to the file with the
.ngfp extension;

2. Make the necessary changes to the form;

3. Save project to file. Select: File -> Save. The resulting file with the .ngfp
extension can be uploaded to a mobile device as a new layer.

8
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3.3 Creating a new form in NextGIS Web

1. Run the program. Create a new project or open an existing one from an .ngfp
file;

2. Set the mode, which automatically creates fields, when controls are created.
The button “Bind elements to fields” should be in pressed state;

3. Add the necessary controls to the form, arranging them in the desired order.
If necessary, follow the additional steps (can be skipped):

• choose different aliases for the fields and rename them, pick the
necessary types in the “Data” menu.

• set the control’s properties in the “Properties” menu;

4. To send ready form to your web GIS, select: Edit -> Upload to NextGIS;

5. In the dialog that opens, specify the connection parameters and click the
“Connect” button:

• URL (name) of your web GIS, for example demo.nextgis.com;

• select the “guest” checkbox if you want to connect to Web GIS without a
login and password. Note: in this case, data collection by using the form
may become unavailable - it all depends on the settings of NextGIS Web
rights for the guest account;

• login;

• password.

6. In the list of resource groups that appear, select a resource group and click
the “Select” button. In the dialog that opens after this (see Fig. ??) , check
the name of the new layer and the type of the geometry and change them if
necessary.

In this dialog you can chose what resources to create in the WebGIS. By default, a
new vector layer with the field structure, defined in the project, will be created
in Web GIS, and the created form will be uploaded to it. You can add this layer as
an item to an existing Collector project. In addition to that, you can also create:

• a new Collector project (a data collection project and a basemap will be
created)

• a new Web Map

To do so, tick the corresponding settings in the dialog.

Click the “Send” button.

If it wasn’t possible to create a layer (there is no connection to the Internet, the
name of the layer is not unique, etc.), a corresponding message will appear.

If the name of the layer is not unique, you can change it either by selecting Edit
-> Form Properties -> Name (by default the name is “Layer”), or when uploading
the form to WebGIS.

3.3. Creating a new form in NextGIS Web 9
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Рис.3.1: Form properties dialog

3.3. Creating a new form in NextGIS Web 10
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Note: To collect data on your mobile device follow the instructions of NextGIS
Mobile/Collector. The data collected by using the form will be synchronized with
the layer automatically.

3.4 Creating a new form in NextGIS Web using existed
layer

1. Run the program. Select: Edit -> Download from NextGIS;

2. In the dialog that opens, specify the connection parameters and click the
“Connect” button:

• URL (name) of your web GIS, for example demo.nextgis.com;

• select the “guest” checkbox if you want to connect to Web GIS without a
login and password. Note: in this case, not all layers or resource groups
may be visible - it all depends on the settings of NextGIS Web rights for
the guest account;

• login;

• password.

3. In the resource list that appears, select a resource with the “Vector layer”
type and click the “Select” button. If the connection is successful, the data
structure of the layer will be uploaded, as well as the existing form (if it
already exists for the selected layer);

4. Make changes to the form. If there is no form initially, but you need to create it
for an existing field structure - turn off the automatic field creation mode: the
button “Bind elements to fields” should be in unpressed state. Place controls
on the form. After that, connect the the fields with these controls through the
“Field Layer” property in the “Properties” menu of the control. As a result,
in the “Data” menu all fields should have green “ok” markers, indicating
that the fields are successfully connected with the controls, and the controls
themselves should not have red markers with an exclamation mark.

5. Upload the modified form to NextGIS Web (see the section “Creating a
New Form in NextGIS Web”). Please note that you cannot change existing
resources this way; in any case, a new layer will be created and a form will be
uploaded to it. If the layer you selected at the beginning had data, then this
data will be copied to the new layer if fields match.

3.4. Creating a new form in NextGIS Web using existed layer 11
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FOUR

FORM CONTROLS

4.1 Tabs

Tabs grouping for other elements.

Properties:

• Current page. Current page which should be displayed by default.

• Headers. A list of header strings.

4.2 Date & time

An element which allows to pick a date, time or date&time value.

Properties:

• Is current. Automatically assigns current value during the data collecting
process. Otherwise user will be able to pick it manually.

• Type. Type.

• Initial value. Initial fixed date/time value.

• Keep last value. Whether to keep last entered value for this element during
data collecting process.

4.3 Distance meter

This element automatically measures distance between current position of the
point and current position of the surveyor.

12
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4.4 Dependent comboboxes

A pair of drop-down lists with predefined items. The item list of the dependent
combobox depends on the items of the main combobox.

Properties:

• Items. Lists of items for both comboboxes.

• Keep last value. Whether to keep last entered value for this element during
data collecting process.

4.5 Coordinates

An element which automatically saves current geographical coordinates in text
format.

Properties:

• Is hidden. Do not show this element. The coordinates will be written to the
layer’s field(s) anyway.

• CRS. Coordinate Reference System.

• Format. The format of the string which will be written to the layer’s field(s).

4.6 Label

An element which displays static text

Properties:

• Text. Displayed text.

4.7 Signature field

A field for signature.

4.8 Void space

Void space for making indents.

4.4. Dependent comboboxes 13
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4.9 Radiogroup

A list with predefined items which allows the selection of only one value.

Properties:

• Keep last value. Whether to keep last entered value for this element during
data collecting process.

• Items. A list of items (must have at least two items).

4.10 Splitted combobox

A drop-down list with predefined items splitted by two parts. Each item has an
inner value for saving and a pair of displayed values. E.g. the collector will be able
to see the same item but in different languages.

Properties:

• Caption (left). Static text which will be placed above this element (at left).

• Caption (right). Static text which will be placed above this element (at
right).

• Items. A list of items.

• Keep last value. Whether to keep last entered value for this element during
data collecting process.

4.11 Combobox

A drop-down list with predefined itemswhich allows the selection of only one value.

Properties:

• Items. A list of items.

• Keep last value. Whether to keep last entered value for this element during
data collecting process.

• Own items. User can add own items to this combobox.

• Input with search. Whether to show or not corresponding items during
typing in this combobox.

4.9. Radiogroup 14
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4.12 Counter

An element which automatically adds values based on some predefined format.

Properties:

• Increment. The value which is added to the current counter’s value each
time user collects data about an object.

• Initial value. Initial value from which incrementing starts.

• Prefix. A text which is added before the counter’s value. If this text is not void
the counter writes its value as a string.

• Suffix. A text which is added after the counter’s value. If this text is not void
the counter writes its value as a string.

• Prefix from list. Prefix from list.

• Suffix from list. Suffix from list.

4.13 Average counter

An element which counts an average value from some amount of entered values.

Properties:

• Number of values. How many values a collector can enter to count an
average value.

4.14 Text edit

An element for editing simple text or numbers.

Properties:

• Initial text. Initial text.

• Keep last value. Whether to keep last entered value for this element during
data collecting process.

• Max. lines count. Maximum number of lines for this text edit.

• NextGIS ID login. The value in this text edit will be replaced with user’s
NextGIS ID login.

• NextGIS Web login. The value in this text edit will be replaced with user’s
login if the connection with NextGIS Web is established during the data
collecting process.

• Only numbers. This element can accept only numbers.

4.12. Counter 15
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4.15 Checkbox

An element which allows user to pick from two values: true or false.

Properties:

• Initial value. Initial value.

• Keep last value. Whether to keep last entered value for this element during
data collecting process.

• Text. Displayed text

4.16 Photo

An element which allows to take photos with embedded camera or to add them
from the gallery.

Properties:

• Max. photo count. Maximum number of photos.

• Comment. Comment under photo(s).

4.15. Checkbox 16
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FIVE

Глоссарий

геоинформационные системы
Информационная система, оперирующая пространственными данными
(они же геоданные). [ГОСТ Р 52438-2005 “Географические информаци-
онные системы. Термины и определения”]

данные
Информация, представленная в виде, пригодном для обработки автома-
тическими средствами при возможном участии человека. [ГОСТ 15971-
90, статья 1]
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Приложение

A

GNU GENERAL PUBLIC LICENSE, VERSION 2

GNU GENERAL PUBLIC LICENSE

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 51 Franklin Street, Fifth
Floor, Boston, MA 02110-1301, USA

Everyone is permitted to copy and distribute verbatim copies of this license
document, but changing it is not allowed.

A.1 Preamble

The licenses for most software are designed to take away your freedom
to share and change it. By contrast, the GNU General Public License
is intended to guarantee your freedom to share and change free
software–to make sure the software is free for all its users. This General
Public License applies to most of the Free Software Foundation’s
software and to any other program whose authors commit to using
it. (Some other Free Software Foundation software is covered by the
GNU Lesser General Public License instead.) You can apply it to your
programs, too.

When we speak of free software, we are referring to freedom, not price. Our
General Public Licenses are designed to make sure that you have the freedom to
distribute copies of free software (and charge for this service if you wish), that you
receive source code or can get it if you want it, that you can change the software or
use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny
you these rights or to ask you to surrender the rights. These restrictions translate
to certain responsibilities for you if you distribute copies of the software, or if you
modify it.

For example, if you distribute copies of such a program, whether gratis or for a
fee, you must give the recipients all the rights that you have. You must make sure
that they, too, receive or can get the source code. And you must show them these
terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you
this license which gives you legal permission to copy, distribute and/or modify the
software.

18
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Also, for each author’s protection and ours, we want to make certain that everyone
understands that there is no warranty for this free software. If the software is
modified by someone else and passed on, we want its recipients to know that what
they have is not the original, so that any problems introduced by others will not
reflect on the original authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish
to avoid the danger that redistributors of a free program will individually obtain
patent licenses, in effect making the program proprietary. To prevent this, we
have made it clear that any patent must be licensed for everyone’s free use or
not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

A.2 TERMS AND CONDITIONS FOR COPYING,
DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice
placed by the copyright holder saying it may be distributed under the
terms of this General Public License. The “Program”, below, refers to
any such program or work, and a “work based on the Program” means
either the Program or any derivative work under copyright law: that is to
say, a work containing the Program or a portion of it, either verbatim or
with modifications and/or translated into another language. (Hereinafter,
translation is included without limitation in the term “modification”.) Each
licensee is addressed as “you”.

Activities other than copying, distribution and modification are not covered by
this License; they are outside its scope. The act of running the Program is
not restricted, and the output from the Program is covered only if its contents
constitute a work based on the Program (independent of having been made by
running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program’s source code
as you receive it, in any medium, provided that you conspicuously and
appropriately publish on each copy an appropriate copyright notice and
disclaimer of warranty; keep intact all the notices that refer to this License
and to the absence of any warranty; and give any other recipients of the
Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at
your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it,
thus forming a work based on the Program, and copy and distribute such
modifications or work under the terms of Section 1 above, provided that you
also meet all of these conditions:

a) You must cause the modified files to carry prominent notices stating that
you changed the files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or
in part contains or is derived from the Program or any part thereof, to be

A.2. TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND
MODIFICATION
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licensed as a whole at no charge to all third parties under the terms of
this License.

c) If the modified program normally reads commands interactively when
run, you must cause it, when started running for such interactive use in
the most ordinary way, to print or display an announcement including an
appropriate copyright notice and a notice that there is no warranty (or
else, saying that you provide a warranty) and that users may redistribute
the program under these conditions, and telling the user how to view a
copy of this License. (Exception: if the Program itself is interactive but
does not normally print such an announcement, your work based on the
Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections
of that work are not derived from the Program, and can be reasonably considered
independent and separate works in themselves, then this License, and its terms,
do not apply to those sections when you distribute them as separate works. But
when you distribute the same sections as part of a whole which is a work based on
the Program, the distribution of the whole must be on the terms of this License,
whose permissions for other licensees extend to the entire whole, and thus to each
and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to
work written entirely by you; rather, the intent is to exercise the right to control
the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with
the Program (or with a work based on the Program) on a volume of a storage or
distribution medium does not bring the other work under the scope of this License.

3. Youmay copy and distribute the Program (or a work based on it, under Section
2) in object code or executable form under the terms of Sections 1 and 2 above
provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source
code, which must be distributed under the terms of Sections 1 and 2
above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to
give any third party, for a charge no more than your cost of physically
performing source distribution, a complete machine-readable copy of the
corresponding source code, to be distributed under the terms of Sections
1 and 2 above on a medium customarily used for software interchange;
or,

c) Accompany it with the information you received as to the offer to
distribute corresponding source code. (This alternative is allowed only
for noncommercial distribution and only if you received the program
in object code or executable form with such an offer, in accord with
Subsection b above.)

The source code for a work means the preferred form of the work for making
modifications to it. For an executable work, complete source code means all the
source code for all modules it contains, plus any associated interface definition
files, plus the scripts used to control compilation and installation of the executable.
However, as a special exception, the source code distributed need not include

A.2. TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND
MODIFICATION
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anything that is normally distributed (in either source or binary form) with the
major components (compiler, kernel, and so on) of the operating system on which
the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from
a designated place, then offering equivalent access to copy the source code from
the same place counts as distribution of the source code, even though third parties
are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as
expressly provided under this License. Any attempt otherwise to copy, modify,
sublicense or distribute the Program is void, and will automatically terminate
your rights under this License. However, parties who have received copies,
or rights, from you under this License will not have their licenses terminated
so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it.
However, nothing else grants you permission to modify or distribute the
Program or its derivative works. These actions are prohibited by law if you do
not accept this License. Therefore, by modifying or distributing the Program
(or any work based on the Program), you indicate your acceptance of this
License to do so, and all its terms and conditions for copying, distributing or
modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program),
the recipient automatically receives a license from the original licensor to
copy, distribute or modify the Program subject to these terms and conditions.
You may not impose any further restrictions on the recipients’ exercise of the
rights granted herein. You are not responsible for enforcing compliance by
third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement
or for any other reason (not limited to patent issues), conditions are imposed
on you (whether by court order, agreement or otherwise) that contradict
the conditions of this License, they do not excuse you from the conditions
of this License. If you cannot distribute so as to satisfy simultaneously your
obligations under this License and any other pertinent obligations, then as
a consequence you may not distribute the Program at all. For example, if a
patent license would not permit royalty-free redistribution of the Program by
all those who receive copies directly or indirectly through you, then the only
way you could satisfy both it and this License would be to refrain entirely
from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular
circumstance, the balance of the section is intended to apply and the section as a
whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or
other property right claims or to contest validity of any such claims; this section
has the sole purpose of protecting the integrity of the free software distribution
system, which is implemented by public license practices. Many people have
made generous contributions to the wide range of software distributed through
that system in reliance on consistent application of that system; it is up to the
author/donor to decide if he or she is willing to distribute software through any
other system and a licensee cannot impose that choice.

A.2. TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND
MODIFICATION
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This section is intended to make thoroughly clear what is believed to be a
consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries
either by patents or by copyrighted interfaces, the original copyright holder
who places the Program under this License may add an explicit geographical
distribution limitation excluding those countries, so that distribution is
permitted only in or among countries not thus excluded. In such case, this
License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the
General Public License from time to time. Such new versions will be similar in
spirit to the present version, but may differ in detail to address new problems
or concerns.

Each version is given a distinguishing version number. If the Program specifies
a version number of this License which applies to it and “any later version”, you
have the option of following the terms and conditions either of that version or of
any later version published by the Free Software Foundation. If the Program does
not specify a version number of this License, you may choose any version ever
published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs
whose distribution conditions are different, write to the author to ask
for permission. For software which is copyrighted by the Free Software
Foundation, write to the Free Software Foundation; we sometimes make
exceptions for this. Our decision will be guided by the two goals of preserving
the free status of all derivatives of our free software and of promoting the
sharing and reuse of software generally.

A.3 NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS
NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY
APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE
COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM
“AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIEDWARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE
PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE,
YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR
CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO
INWRITINGWILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTYWHO
MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED
ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL,
SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF
THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT
LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR
LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE
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PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH
HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES.
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